Uconnect/Guardian

CBs / FRS / GMRS / MARS, radios, stereos, computers, tools, etc. The stuff you use to support wheeling or use of your PW.
Post Reply
ArmageddonKaine
Posts: 5
Joined: Tue Nov 13, 2018 8:05 pm
Model Year: 2018

Uconnect/Guardian

Post by ArmageddonKaine » Wed Dec 26, 2018 11:56 pm

Hey All,

Sorry if I'm posting in wrong area or even if this applies to this forum. Is anyone using Uconnect/Guardian on their PW? I activated the free subscription and I am having problems with it. The whole Guardian/Uconnect/Moper set up is a convoluted mess. I keep going in circles trying to get help. Anyway, It's installed but only works for a short time after using the phone app after the vehicle has been entered turned on with the key and turned back off. Kind of defeats the purpose. I haven't tested how long after turning off the vehicle it works but after an hour it stops working again. I get errors stating ucoonnect failed to connect. I searched the internet and I see people having similar problems on other Mopar vehicles but there are no solutions. It's like something is being powered for a short time after the PW is turned off then once that goes I can no longer use the app until I go out and start the vehicle again. It's obviously a communication problem. Let me know if anyone else has that problem and how you fixed it. As it stands, I wont waste a cent on this subscription it's so bad but was hoping not to have to carry the spare key and use uconnect as my back up.

Thanks.

EasyDoesIt
50_Posts
50_Posts
Posts: 206
Joined: Fri Jan 05, 2018 11:32 am
Model Year: 2018
Location: Las Vegas, NV

Re: Uconnect/Guardian

Post by EasyDoesIt » Thu Dec 27, 2018 12:54 am

I'm still within the free period on my 2018 and use it a few times a month when I need to get something out of my truck but the keys are all the way inside. :lol: I've used it on two different android devices (LG V30 and Pixel 3) and although its a bit slow to respond, it does work.

Its gimmicky and I wont be renewing my subscription but it is a cool feature. For us non push to start guys, it could come in handy if you lock the keys in the truck but (knock on wood) I haven't done that in 15+ years.
  • Have you tried to uninstall and reinstall the app?
  • Confirmed your phone/software version is compatible?
  • Maybe disconnect the PW battery and/or pull the applicable fuses to try and reset the system?
Live: Las Vegas NV, Drive: 2018 PW & 2014 LR4

DirtyOffroad
Posts: 44
Joined: Mon Dec 04, 2017 12:46 pm
Model Year: 2014

Re: Uconnect/Guardian

Post by DirtyOffroad » Sat Jan 26, 2019 9:49 am

There was an issue with the app and there should be an update available for you. I would delete the app and install brand new from the app store.
2018 Ram 2500 Powerwagon
1.5 Thuren - Front
Thuren Rear Track Bar
LED Headlights and Fog
37x12.5x17 Toyo Open Country M/T

Merrick Dodge/Chryler/Jeep Salesman - Long Island, New York.

User avatar
Onlyone
Posts: 39
Joined: Sun Dec 30, 2018 6:52 pm
Model Year: 2018
Location: Eagle, Colorado

Re: Uconnect/Guardian

Post by Onlyone » Sun Feb 03, 2019 7:02 pm

It works....sometimes. Really slow. I don’t hate it but I dont think I’ll ever pay for it in the future, unless it is improved 10 fold.
I’ve had the connection problem and many times it reboots the app and then the actual truck changes. Then it says it started but didn’t. Ect.
2018 Power Wagon. Granite Crystal.
37-12.50-17 KO2s

GreggNY
Posts: 6
Joined: Thu Jun 06, 2019 1:10 pm
Model Year: 2018
Location: New York

Re: Uconnect/Guardian

Post by GreggNY » Mon Jun 10, 2019 12:54 am

Ditto to the above responses. I thought it would be cool to activate the valet feature if I ever had to valet the truck. Now I can’t figure out how to turn it off so I get a notification every time I drive it that the valet has gone outside of my set mile radius lol. Still can’t find in the settings where to turn it off

Post Reply